pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39317: MesaLib-7.0.3 doesn't build if i386 option is enabled

        Note: There was a bad value `' for the field `Severity'.
        It was set to the default value of `serious'.

>Number:         39317
>Category:       pkg
>Synopsis:       MesaLib 7.0.3 fails to build if i386 PKG_OPTION is enabled
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Aug 07 23:10:00 +0000 2008
>Originator:     Christoph Badura
>Release:        NetBSD 3.1_STABLE
        pkgsrc-2008Q2 on the evening of the branch tagging.
System: NetBSD nervous-energy 3.1_STABLE NetBSD 3.1_STABLE (nervous-energy) #4: 
Fri Jul 25 06:31:02 MEST 2008 
root@nervous-energy:/src/sys/arch/i386/compile/nervous-energy i386
Architecture: i386
Machine: i386
The supported build options for MesaLib are:

        dri i386 mesa-execmem-mmap

The currently selected options are:

        i386 mesa-execmem-mmap

You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

        PKG_OPTIONS.MesaLib = i386


# never mind that "Its current value is shown:" and "The currently selected
# options are:" do not match.

===> Patching for MesaLib-
=> Applying distribution patches for MesaLib-
=> Applying pkgsrc patches for MesaLib-  
=> Teaching glapi about NetBSD thread stubs
/bin/cp /usr/pkgsrc/graphics/MesaLib/../MesaLib/files/configs/[d-z]* /pkg_comp/o
===> Creating toolchain wrappers for MesaLib-
===> Building for MesaLib-
cd /pkg_comp/obj/pkgsrc/graphics/MesaLib/default/Mesa-7.0.3 && /bin/rm -fr src/g
lu src/glut progs
gmake: *** No rule to make target `pkgsrc-i386'.  Stop.
*** Error code 2

check out pkgsrc-2008Q2
echo "PKG_DEFAULT_OPTIONS=i386" >>/etc/mk.conf
cd graphics/MesaLib && make


Home | Main Index | Thread Index | Old Index