pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39247: archivers/rar won't build

>Number:         39247
>Category:       pkg
>Synopsis:       archivers/rar won't build
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jul 29 16:05:00 +0000 2008
>Originator:     Bernd Ernesti
>Release:        NetBSD 4.99.71
System: NetBSD 4.99.70
Architecture: i386
Machine: i386
        The outdated bsd binary does not work anymore and you will see
        this when you try to build it:

check-ksyms: symbol exec_nomid not found in /netbsd
In order to extract this package, you must have have booted from a
kernel with options COMPAT_NOMID and COMPAT_12, and EXEC_AOUT if on
an ELF system.
*** Error code 1

        See this thread too:

        cd pkgsrc/archivers/rar
        make install
        Get rid of the outdated bsd binary package and use the linux
        binary package.

Home | Main Index | Thread Index | Old Index