pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39148: mail/postfix broken in recent DragonFly

>Number:         39148
>Category:       pkg
>Synopsis:       mail/postfix broken in recent DragonFly
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jul 15 07:05:00 +0000 2008
>Originator:     Hasso Tepper
>Release:        DragonFly
Recent boost of DragonFly version number to 2.x (2.0 release planned in 20th 
July) broke mail/postfix:

ATTENTION: Unknown system type: DragonFly 2.1-DEVELOPMENT
*** Error code 1


The problem is there because of IMHO stupid check for OS version - checking 
DragonFly major version gives nothing (the same is true for most of other BSDs 

Trivial patch to fix the problem is available at

Home | Main Index | Thread Index | Old Index