pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39120: Installing language bindings to subversion fails

>Number:         39120
>Category:       pkg
>Synopsis:       Installing language bindings to subversion fails
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jul 09 20:35:01 +0000 2008
>Originator:     Hasso Tepper
>Release:        DragonFly
Installing all language bindings to subversion (and probably other packages 
depending on subversion) fail for similar reason:

===> Creating toolchain wrappers for p5-subversion-1.5.0
ERROR: cyrus-sasl>=2.1.12 is not installed; can't buildlink files.
*** Error code 1

Try to build perl, python, ruby etc bindings to subversion without 
security/cyrus-sasl installed.
The reason is that devel/subversion-base/ includes 
../../security/cyrus-sasl/ unconditionally. Putting it between .if 
!empty(PKG_OPTIONS:Msasl) fixes the problem.

Home | Main Index | Thread Index | Old Index