pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/38983: sendmail doesn't compile on i386-current

>Number:         38983
>Category:       pkg
>Synopsis:       sendmail doesn't compile on i386-current
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 18 21:20:01 +0000 2008
>Originator:     H. Todd Fujinaka
>Release:        NetBSD 4.99.65
System: NetBSD 4.99.65 NetBSD 4.99.65 (AMTTEST) #197: Wed Jun 
18 00:01:29 PDT 2008 i386
Architecture: i386
Machine: i386
sendmail doesn't compile on i386-current. This is critical because sendmail 
used to be the default mailer and this is the semi-official way to get it 
installed now.

Here's the error (which repeats in several modules):

Configuration: pfx=, os=NetBSD, rel=4.99.65, rbase=4, rroot=4.99, arch=i386, 
sfx=, variant=optimized
Making in 
-I/usr/pkg/include -DSMRSH_CMDDIR=\"/usr/pkg/libexec/sm.bin\"     -DNETINET6 
-DNEEDSGETIPNODE -DTCPWRAPPERS  -I/usr/include -c debug.c
debug.c:390: error: conflicting types for 'sm_debug_loadactive'
../../include/sm/debug.h:123: error: previous declaration of 
'sm_debug_loadactive' was here
*** Error code 1

        cd pkgsrc/mail/sendmail; make update



Home | Main Index | Thread Index | Old Index