pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/38946: weechat: add perl and ruby plugin support

On Thu, 12 Jun 2008, wrote:

> 2. Add a block in to support Perl and Ruby, similar to Python:
> .if !empty(PKG_OPTIONS:Mperl)
> .include "../../lang/perl5/"
> CONFIGURE_ARGS+=        --enable-perl
> PLIST.python=           yes

PLIST.perl and added needed entry to the PLIST.

> .else
> CONFIGURE_ARGS+=        --disable-perl
> .endif
> .if !empty(PKG_OPTIONS:Mruby)
> .include "../../lang/ruby/"
> CONFIGURE_ARGS+=        --enable-ruby
> PLIST.python=           yes

PLIST.ruby and added needed entry to PLIST file.

Maybe do same for aspell too.

Home | Main Index | Thread Index | Old Index