pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/38926: graphics/kdegraphics3 requires devel/libltdl to compile

>Number:         38926
>Category:       pkg
>Synopsis:       graphics/kdegraphics3 requires devel/libltdl to compile
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 10 03:30:00 +0000 2008
>Originator:     David H. Gutteridge
>Release:        NetBSD 4.0

#0: Mon Apr 21 17:42:10 EDT 2008  
Architecture: powerpc
Machine: macppc
When trying to compile kdegraphics with pkgrsc as of this evening,
I encountered the following:

=> Bootstrap dependency digest>=20010302: found digest-20070803
===> Checking for vulnerabilities in kdegraphics-3.5.9
=> Checksum SHA1 OK for kdegraphics-3.5.9.tar.bz2
=> Checksum RMD160 OK for kdegraphics-3.5.9.tar.bz2
===> Installing dependencies for kdegraphics-3.5.9
The following variables will affect the build process of this package,
kdegraphics-3.5.9.  Their current value is shown below:

        * BDB185_DEFAULT = db1
        * BDB_DEFAULT = db4
        * KRB5_DEFAULT = heimdal
        * SSLBASE = /usr
        * SSLCERTS = /etc/openssl/certs
        * SSLDIR = /etc/openssl
        * SSLKEYS = /etc/openssl/private

Based on these variables, the following variables have been set:

        * BDBBASE = /usr
        * BDB_LIBS (defined, but empty)
        * BDB_TYPE = db1
        * KRB5BASE (defined, but empty)
        * KRB5_TYPE = heimdal

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency libtool-base>=1.5.18nb5: found libtool-base-1.5.24nb5
=> Build dependency xpkgwedge>=1.15: found xpkgwedge-1.16
=> Build dependency gmake>=3.81: found gmake-3.81
=> Build dependency perl>=5.0: found perl-5.8.8nb8
=> Build dependency pkg-config>=0.19: found pkg-config-0.22
=> Build dependency x11-links>=0.35: found x11-links-0.35
=> Build dependency qt3-tools>=3.3.6nb1: found qt3-tools-3.3.8nb1
=> Build dependency renderproto>=0.9.3nb1: found renderproto-0.9.3nb1
=> Build dependency randrproto>=1.2.0: found randrproto-1.2.1
=> Build dependency fixesproto>=3.0.0: found fixesproto-4.0
=> Build dependency inputproto>=1.4: found inputproto-
=> Full dependency xdg-dirs>=1.2: found xdg-dirs-1.4
=> Full dependency kde3-dirs>=1.0: found kde3-dirs-1.0
=> Full dependency 
{ghostscript,ghostscript-afpl,ghostscript-esp,ghostscript-gnu}>=6.01: found 
=> Full dependency fribidi>=0.10.4nb1: found fribidi-0.10.4nb1
=> Full dependency libgphoto2>=2.1.6nb1: found libgphoto2-2.3.1nb4
=> Full dependency glut>=7.0.3: found glut-
=> Full dependency hicolor-icon-theme>=0.9nb1: found 
=> Full dependency imlib>=1.9.15nb4: found imlib-1.9.15nb4
=> Full dependency sane-backends>=1.0.17nb1: found sane-backends-1.0.18
=> Full dependency poppler-qt>=0.4.5nb1: found poppler-qt-0.8.0
=> Full dependency kdebase>=3.5.8nb5: found kdebase-3.5.9
=> Full dependency kdelibs>=3.5.8nb5: found kdelibs-3.5.9nb1
=> Full dependency openexr>=1.6.1: found openexr-1.6.1
=> Full dependency tiff>=3.7.2nb1: found tiff-3.8.2nb3
=> Full dependency qt3-libs>=3.3.6nb1: found qt3-libs-3.3.8nb7
===> Overriding tools for kdegraphics-3.5.9
===> Extracting for kdegraphics-3.5.9
===> Patching for kdegraphics-3.5.9
=> Fixing hardcoded paths.
INFO: [] Nothing changed in ./kpdf/xpdf/xpdf/
===> Creating toolchain wrappers for kdegraphics-3.5.9
ERROR: libltdl is not installed; can't buildlink files.
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/kdegraphics3
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/kdegraphics3

As above.

(Add libltdl as a build-time dependency for kdegraphics3?)


Home | Main Index | Thread Index | Old Index