pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/38794: bootstrap fails on IRIX

The following reply was made to PR pkg/38794; it has been noted by GNATS.

From: "Stuart Shelton" <>
Subject: Re: pkg/38794: bootstrap fails on IRIX
Date: Fri, 30 May 2008 17:57:01 +0100

 Bear in mind that this is bootstrapping to restore an erased bmake,
 not on a pkgsrc-less system.
 Having said this, it does look as if removing nbcompat* from
 $PKGSRC/include did the trick... someone should probably check why
 this is happening though, so that re-running bootstrap is possible if
 I now have a greater problem: bootstrapping has completed, and I have
 bmake installed again.  But for all of the packages which are now
 marked as "not for deletion" I can't do anything with them!  Running
 bmake with arguments "reinstall", "update", "replace", or "install"
 all results in a "ERROR: <package> is already installed - perhaps an
 older version".
 Will this go away as updates to each package are released?
 (I was trying to rebuild bmake from the installed system, in case
 there is any difference between this and the bootstrapped version)

Home | Main Index | Thread Index | Old Index