pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/38598 (www/py-moin wiki requires security update)

The following reply was made to PR pkg/38598; it has been noted by GNATS.

From: George Georgalis <>
Subject: Re: pkg/38598 (www/py-moin wiki requires security update)
Date: Mon, 19 May 2008 21:04:00 -0400

 On Thu 08 May 2008 at 03:25:03 PM +0000, Joerg Sonnenberger wrote:
 > On Thu, May 08, 2008 at 01:40:02PM +0000, George Georgalis wrote:
 > >  I do have farmconfig in the proper location, so I'm not
 > >  sure if this is a local issue or in the pkg.  Is the pkg
 > >  working for you?
 > Yes, it is. You have to create the file yourself and adjust the module
 > path accordingly.
 The rather obscure error I got was:
 ImportError: No module named wikiconfig
 Check that the file is in the same directory as the server script. If it is 
not, you must add the path of the directory where the file is located to the 
python path in the server script. See the comments at the top of the server 
 Check that the configuration file name is either "" or the module 
name specified in the wikis list in Note that the module name 
does not include the ".py" suffix.
 Error in your configuration file 
"/usr/pkg/lib/python2.4/site-packages/MoinMoin/config/" around 
line 38.
 As it turns out that was because I didn't update
 (migrate 1.5.x to 1.6.3) the following in my
     #from MoinMoin.util.antispam import SecurityPolicy                         
     from import SecurityPolicy                      
 which is documented in docs/changes, upstream is aware
 of the unclear error and will probably revise for next
 pr closed.
 // George 
 George Georgalis, information system scientist <IXOYE><

Home | Main Index | Thread Index | Old Index