pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/38651: libkver won't install in pkg_comp any more

>Number:         38651
>Category:       pkg
>Synopsis:       libkver won't install in pkg_comp any more
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue May 13 11:30:00 +0000 2008
>Originator:     Robert Elz
>Release:        NetBSD 3.99.15 (pkgsrc current today - or anytime in last 
        Prince of Songkla University
System: NetBSD 3.99.15 NetBSD 3.99.15 
(GENERIC-1.696-20060125) #8: Wed Jan 25 04:59:39 ICT 2006 i386
Architecture: i386
Machine: i386
        pkg_comp uses libkver to similate a particular version of
        NetBSD in its arena, so packages can be built that run on
        any (older) desired version of NetBSD.

        Or it should.

        For the past month or so, pkg_comp has been unable to install
        libkver - instead it installs a version of pkg_tools in the
        /libkver directory within the pkg_comp arena.

        pkg_comp removeroot
        build a pkg_comp config file with NETBSD_RELEASE set
                (and an appropriate set of binary sets, though
                for present purposes, "appropriate" doesn't really
        pkg_comp makeroot

        After that anything attempted with pkg_comp will complain about
        not being able to load /libkver/ (or something like
        that) - not surprising, as the llibrary never gets created
        (though the instructions to use it do)

        No idea.   I suspect something may be broken in the way that
        pkgsrc decides to update its pkg_tools, along with the way
        standalone packages modify PREFIX to get themselves installed
        outside the normal /usr/pkg tree.   libkver attempts to
        defeat that by explcictly saying not to check the pkgtools
        version, and just use whatever comes - but it looks as if that
        ability no longer exists).

        A fix for this is important, pkg_comp with libkver is the
        truly sane way to build packages and maintain /usr/pkg, nothing
        else comes remotely close.

Home | Main Index | Thread Index | Old Index