pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/38505: `make replace` fails as non-root

>Number:         38505
>Category:       pkg
>Synopsis:       `make replace` fails as non-root
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Apr 25 11:50:00 +0000 2008
>Originator:     moof
>Release:        NetBSD 4.99.40
System: NetBSD 4.99.40 NetBSD 4.99.40 (BURAI) #3: Fri Jan 25 
13:32:46 JST 2008
Architecture: i386
Machine: i386
If one tries to `make replace` as non-root, the following happens:

===> Replacing for libX11-1.1.4nb1
WARNING: experimental target - DATA LOSS MAY OCCUR.
=> Becoming ``root'' to make su-replace (/usr/pkg/bin/sudo)
Creating binary package: libX11-1.1.3
Creating package /var/tmp/pkgsrc/x11/libX11/work.i386/libX11-1.1.3
Using SrcDir value of /usr/pkg
=> Preserving existing +INSTALLED_INFO file.
=> Preserving existing +REQUIRED_BY file.
===> Deinstalling for libX11-1.1.4nb1
Running /usr/pkg/sbin/pkg_delete -K /var/db/pkg  libX11-1.1.3
=> Bootstrap dependency digest>=20010302: found digest-20070803
===> Checking for vulnerabilities in libX11-1.1.4nb1
=> Fixing @pkgdep entries in dependent packages.
mv: rename /var/tmp/pkgsrc/x11/libX11/work.i386/.replace-+REQUIRED_BY to 
/var/db/pkg/libX11-1.1.4nb1/+REQUIRED_BY: No such file or directory

try `make replace` as non-root.


Home | Main Index | Thread Index | Old Index