pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/38395 (due to API changes please bump BUILDLINK_API_DEPENDS)

The following reply was made to PR pkg/38395; it has been noted by GNATS.

From: Andreas Hallmann <>
Subject: Re: pkg/38395 (due to API changes please bump BUILDLINK_API_DEPENDS)
Date: Wed, 09 Apr 2008 22:15:50 +0200 schrieb:
 > Synopsis: due to API changes please bump BUILDLINK_API_DEPENDS
 > State-Changed-From-To: open->feedback
 > State-Changed-By:
 > State-Changed-When: Wed, 09 Apr 2008 19:39:53 +0000
 > State-Changed-Why:
 > We'll add the proper dependency when cairo is next updated, in
 > cairo's Makefile. Why should we add it now and for all of
 > pixman's dependencies?
 Well the API has changed. An binary package compiled against 0.10.0 
 can't be garantied to run with 0.9.6.
 I thought, this is what is expressed by the submitted patch. But I might 
 be mistaken.
 cairo's developer snapshots 1.5.20 compiled against pixman 0.10.0  is 
 only an example of a binary which will break, if linked against a 0.9.6 
 Of course, we can patch all Makefiles of packages which are really using 
 thoose changes. But this can be a major investigation in general.
 The decision is up to the more expirienced, i.e. you.

Home | Main Index | Thread Index | Old Index