pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/38389: pkgsrc-2008Q1 bootstrap fails on MacOS X 10.4.11 (PPC)

>Number:         38389
>Category:       pkg
>Synopsis:       pkgsrc-2008Q1 bootstrap fails on MacOS X 10.4.11 (PPC)
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Apr 08 22:25:00 +0000 2008
>Originator:     John D. Baker
>Release:        MacOS X 10.4.11 (PPC), pkgsrc-2008Q1
Darwin g4gbe.technoskunk.fur 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 
18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc

bootstrapping pkgsrc-2008Q1 on MacOS X 10.4.11 (PPC) (others?) fails
as follows:

===> Configuring for bootstrap-mk-files-20080310
 for file in bsd.*; do                     test ! -f mods/Darwin.$file 
||                  /bin/cp -f mods/Darwin.$file 
                                                  if test -f 
mods/; then                      
own_mk=mods/;                       else                    
fi;                     /usr/bin/sed   -e 's|@ROOT_GROUP@|'wheel'|g'            
        -e 's|@ROOT_USER@|'root'|g'                     -e 
's|@SYSCONFDIR@|'/usr/pkg/etc'|g'            $own_mk >
===> Installing for bootstrap-mk-files-20080310
ERROR: bootstrap-mk-files-20080310 is already installed - perhaps an older 
ERROR: If so, you may use either of:
ERROR:     - "pkg_delete bootstrap-mk-files-20080310" and 
"/Volumes/d0/build/pkgsrc/bootstrap/bin/bmake reinstall"
ERROR:       to upgrade properly
ERROR:     - "/Volumes/d0/build/pkgsrc/bootstrap/bin/bmake update" to rebuild 
the package and all
ERROR:       of its dependencies
ERROR:     - "/Volumes/d0/build/pkgsrc/bootstrap/bin/bmake replace" to replace 
only the package without
ERROR:       re-linking dependencies, risking various problems.
*** Error code 1

bmake: stopped in /usr/pkgsrc/pkgtools/bootstrap-mk-files

Since this is the bootstrap operation, NOTHING has been installed,
so the suggested remedy in the error messages will never work.
On clean MacOS X 10.4.11 (PPC) system, or using alternate ${PREFIX},
update pkgsrc to pkgsrc-2008Q1.

Attempt to bootstrap pkgsrc-2008Q1.

Home | Main Index | Thread Index | Old Index