pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/38191: pkgsrc/bootstrap/bootstrap depends on uudecode (in RHEL from sharutils) for libarchive install

>Number:         38191
>Category:       pkg
>Synopsis:       pkgsrc/bootstrap/bootstrap depends on uudecode (in RHEL from 
>sharutils) for libarchive install
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          doc-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Mar 07 08:25:00 +0000 2008
>Originator:     George Michaelson
>Release:        current (pkgsrc)
[ggm@dhcp182 bootstrap]$ uname -a
Linux 2.6.18-8.1.4.el5 #1 SMP Fri May 4 22:15:13 EDT 2007 
i686 i686 i386 GNU/Linux
[ggm@dhcp182 bootstrap]$ 

pkgsrc bootstrap depends on uudecode. In a stripped back Linux, its possible 
not to have this. (we strip, its not there.)

the page mentions some 
dependencies, it might be worth noting this one, or considering internalizing 
the build dependency which drags it in (its libarchive)

uudecode comes from sharutils .rpm.

god, I hate Linux packaging. I hate it.

run a stripped down linux, without uudecode and bootstrap. it will die during 
the libarchive build
either remove the uudecode dependency, internalize it, or document the 

Home | Main Index | Thread Index | Old Index