pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/37929

The following reply was made to PR pkg/37929; it has been noted by GNATS.

From: Aleksej Saushev <>
Subject: Re: pkg/37929
Date: Mon, 04 Feb 2008 13:52:43 +0300

 Well, I've tried to skip this check with
 and with
 CONFIGURE_ENV+=        ac_cv_path_PATCH=${TOOLS_PLATFORM.patch:Q}
 with no success, it still complains "no, GNU XXX is needed."
 Thus I procede with additional depends on devel/patch and
 sysutils/coreutils, providing
 CONFIGURE_ARGS+=       --with-gnu-patch=/usr/pkg/bin/gpatch
 CONFIGURE_ARGS+=       --with-gnu-cp=/usr/pkg/bin/gcp
 as temporary measure (those should be constructed using
 respective variables).
 Now I run into this:
 mkout -- version: 1.7
 /usr/pkg/bin/perl -w 
/var/tmp/pkgobj/local/openoffice2/work/OOG680_m9/solenv/bin/ ../
 copy to ../
 cp: No such file or directory
 copy failed:  at 
/var/tmp/pkgobj/local/openoffice2/work/OOG680_m9/solenv/bin/ line 
 dmake:  Error code 1, while making '../'
 ---* *---
 ERROR: Error 65280 occurred while making 
 dmake:  Error code 1, while making 'build_instsetoo_native'
 It seems that OOo build system incorrectly detects compiler libraries,
 since it requires, while actual is ".5", and "libgcc_s",
 which is absent.
 I've noticed, that OOo is rather old in pkgsrc, it is "OOG680_m9",
 while "m231" is available.  I don't know, if it should be updated,
 since both seem to be development versions, though it would be nice,
 if someone tried that too (I'll try that later, but I lack time,
 and "later" may be distant).

Home | Main Index | Thread Index | Old Index