pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/37796: pkgsrc cannot be bootstrapped on Linux

The following reply was made to PR pkg/37796; it has been noted by GNATS.

From: Joerg Sonnenberger <>
Subject: Re: pkg/37796: pkgsrc cannot be bootstrapped on Linux
Date: Fri, 18 Jan 2008 16:28:42 +0100

 On Fri, Jan 18, 2008 at 11:15:01AM +0000, wrote:
 > pkgsrc-0:/srv/pkgsrc/bootstrap# ./bootstrap --prefix /tmp/pkg_pbulk 
 > --workdir /tmp/tmp-wrk
 > ....
 > config.status: WARNING:  lib/ seems to ignore the --datarootdir 
 > setting
 > config.status: WARNING:  view/ seems to ignore the --datarootdir 
 > setting
 > /bin/sh: /tmp/pkg_pbulk/sbin/audit-packages: No such file or directory
 > WARNING: No /pkg-vulnerabilities file found.
 > WARNING: To fix run: `/tmp/pkg_pbulk/sbin/download-vulnerability-list'.
 > ERROR: bootstrap-mk-files-20070810 is already installed - perhaps an older 
 > version?
 > ERROR: If so, you may use either of:
 > ERROR:     - "pkg_delete bootstrap-mk-files-20070810" and 
 > "/tmp/tmp-wrk/bin/bmake reinstall"
 > ERROR:       to upgrade properly
 > ERROR:     - "/tmp/tmp-wrk/bin/bmake update" to rebuild the package and all
 > ERROR:       of its dependencies
 > ERROR:     - "/tmp/tmp-wrk/bin/bmake replace" to replace only the package 
 > without
 > ERROR:       re-linking dependencies, risking various problems.
 > aborted.
 This looks like you already have part of the prefix existing?
 I certainly bootstrapped on Linux last week.

Home | Main Index | Thread Index | Old Index