pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/37725: sun6-jre does not work on amd64

>Number:         37725
>Category:       pkg
>Synopsis:       sun6-jre does not work on amd64
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 09 12:45:00 +0000 2008
>Originator:     Tero Kivinen
>Release:        NetBSD 4.0_STABLE
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(TIILISKIVI) #0: Tue Dec 18 18:26:01 EET 2007 
root@:/usr/obj/sys/arch/amd64/compile/TIILISKIVI amd64
Architecture: x86_64
Machine: amd64

If I install sun6-jre from the pkgsrc/lang/sun-jre6 it installs i386
version of the java. The wrapper function created to the
pkg/bin/sun6-java uses x86_64 in the LD_LIBRARY_PATH as the
pkgsrc/lang/sun-jre6/Makefile.common defines that
library installed is not in the lib/x86_64/jli but in the lib/i386/jli. 


Install sun6-jre and notice that the INSTALL script running sun6-java
will fail with error complaining that libjli library cannot be found.


This patch fixes the problem:

Index: Makefile.common
RCS file: /cvsroot/pkgsrc/lang/sun-jre6/Makefile.common,v
retrieving revision 1.5
diff -u -r1.5 Makefile.common
--- Makefile.common     22 Aug 2007 14:03:49 -0000      1.5
+++ Makefile.common     9 Jan 2008 12:41:24 -0000
@@ -40,7 +40,7 @@
 JAVA_HOME=             ${LOCALBASE}/java/sun-6
 JAVA_NAME=             sun6
 JAVA_UNLIMIT=          datasize

Home | Main Index | Thread Index | Old Index