pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/37629: security/qca2-ossl depends (incorrectly) on securty/qca

The following reply was made to PR pkg/37629; it has been noted by GNATS.

From: (Eric Schnoebelen)
Subject: Re: pkg/37629: security/qca2-ossl depends (incorrectly) on securty/qca
Date: Thu, 27 Dec 2007 15:20:02 -0600

 Oops, as checked in, chat/psi depends upon qca2-ossl-2.0.0beta,
 in directory ../../security/qca2-ossl.  However, qca2-ossl
 registers itself as qca-ossl. (who's entry also conflicts with
 the Qt3 version of the same, while the packages themselves do
 not conflict.)
 Here is an updated patch to cure that issue as well.
 Index: Makefile
 RCS file: /cvsroot/pkgsrc/security/qca2-ossl/Makefile,v
 retrieving revision
 diff -b -u -w -r1.1.1.1 Makefile
 --- Makefile   20 Dec 2007 20:20:17 -0000
 +++ Makefile   27 Dec 2007 21:19:46 -0000
 @@ -1,7 +1,7 @@
  # $NetBSD: Makefile,v 2007/12/20 20:20:17 jdolecek Exp $
  DISTNAME=     qca-ossl-2.0.0-beta3
 -PKGNAME=      ${DISTNAME:S/-beta/beta/}
 +PKGNAME=      ${DISTNAME:S/qca-/qca2-/:S/-beta/1beta/}
  CATEGORIES=   security
  EXTRACT_SUFX= .tar.bz2
 @@ -19,6 +19,6 @@
  CONFIGURE_ARGS+=      --with-openssl-inc=${SSLBASE}/include
  CONFIGURE_ARGS+=      --with-openssl-lib=${SSLBASE}/lib
 -.include "../../security/qca/"
 +.include "../../security/qca2/"
  .include "../../security/openssl/"
  .include "../../mk/"

Home | Main Index | Thread Index | Old Index