Subject: RE: pkg/37580: wine-0.9.44 does not run run 4.0/i386
To: None <,,,>
From: De Zeurkous <>
List: pkgsrc-bugs
Date: 12/21/2007 22:35:02
The following reply was made to PR pkg/37580; it has been noted by GNATS.

From: "De Zeurkous" <>
Subject: RE: pkg/37580: wine-0.9.44 does not run run 4.0/i386
Date: Fri, 21 Dec 2007 22:30:22 -0000 (UTC)

 > However, POSIX has the letter 'S' in
 > it's name for a reason,
 Although it's not because it stands for 'standard' :X
 Strangely enough, I can still not reproduce the exact message -- have I
 missed a libc setting or some specific value of WINEDEBUG not covered
 under 'all'?
 zeurkous@laagdrave:~$ export WINEDEBUG='all'
 zeurkous@laagdrave:~% winecfg 2>&1 | grep -i 'mutex'
 0009:trace:imports:import_dll --- CreateMutexW kernel32.dll.212 = 0x7fcfb0c8
 0009:trace:imports:import_dll --- ReleaseMutex kernel32.dll.821 = 0x7fcfde88
 0009:Call KERNEL32.CreateMutexW(00000000,00000000,7fa33d20
 L"__WINE_FONT_MUTEX__") ret=7fa0c7d5
 0009:Call ntdll.RtlInitUnicodeString(7fcaf228,7fa33d20
 L"__WINE_FONT_MUTEX__") ret=7fd5fded
 0009: create_mutex( access=001f0001, attributes=000000c0, rootdir=0x24,
 owned=0, name=L"__WINE_FONT_MUTEX__" )
 0009: create_mutex() = 0 { handle=0x28 }
 0009:Ret  KERNEL32.CreateMutexW() retval=00000028 ret=7fa0c7d5
 0009:Call KERNEL32.ReleaseMutex(00000028) ret=7fa0d422
 0009: release_mutex( handle=0x28 )
 0009: release_mutex() = 0 { prev_count=00000001 }
 0009:Ret  KERNEL32.ReleaseMutex() retval=00000001 ret=7fa0d422
 At that moment, wine hangs eating 80% of cpu0, and I have to interrupt it:
 zeurkous@laagdrave:~% ps auwwx | grep 'wine'
 zeurkous 12910 95.8  0.5 29264 10132 ttyp6   RN   10:17PM 0:09.59
 rundll32.exe setupapi.dll,InstallHinfSection DefaultInstall 128 wine.inf 
 zeurkous 15213  0.0  0.1   428  1200 ?       SNs  10:17PM 0:00.04
 /usr/pkg/lib/../bin/wineserver -d
 zeurkous 27733  0.0  0.0   164   660 ttyp6   SN+  10:17PM 0:00.00 grep wine
 zeurkous@laagdrave:~% pkill -KILL wine
 [1]   Killed                  "${WINELOADER:-$...
 That sure does the job, though:
 zeurkous@laagdrave:~% ps auwwx | grep 'wine'
 zeurkous 20075  0.0  0.0  104   552 ttyp6   RN+  10:17PM 0:00.00 grep wine
 The '.wine' directory is still not there, though. Creating it manually
 causes winecfg to work correctly, but still no pthreads in Unreal.
 While I'm at it, lists
 several more PR's. Propose we close them (if they aren't already, don't
 remember the status and I'm too lazy to check :^) and keep this one open,
 as it has the most information.
 I have done /somewhat/ extensive reconfiguration of mk.conf(5) (and my
 -shiny- new pkgsrc.conf), so it might qualify as the cause of the missing
 pthread warnings. Please indicate if it would be useful to post both; I
 believe they're not only readable, but fit for human consumption...
 The final piece of information I can give you right now is that it doesn't
 matter if I build wine with sane _and_ cups or without both; I've not
 tried disabling OpenGL, but since it's an Unreal /server/ I'll see what I
 can do. The results of that new build will probably be my final report for
 --De Zeurkous.