Subject: pkg/37477: pkgsrc/devel/dejagnu not using buildlink3
To: None <,,>
From: bharder <>
List: pkgsrc-bugs
Date: 12/04/2007 11:55:01
>Number:         37477
>Category:       pkg
>Synopsis:       Makefile uses DEPENDS vs. .include
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Dec 04 11:55:01 +0000 2007
>Originator:     bharder <>
>Release:        NetBSD 4.0_RC5
Method Digital Logic (
System: NetBSD manchester 4.0_RC5 NetBSD 4.0_RC5 (manchester) #14: Wed Nov 28 05:02:28 PST 2007 root@manchester:/usr/obj/sys/arch/i386/compile/manchester i386
Architecture: i386
Machine: i386
	Makefile uses:
	DEPENDS+=      tcl-expect>=5.32.1:../../lang/tcl-expect

	where the 'modern' form ought to be:
	.include "../../lang/tcl-expect/"

	iiuc. I don't know if this will functionally affect anything, but ought to satisfy pedants.
	grep expect pkgsrc/devel/dejagnu/Makefile
	patch against Makefile:

--- ./Makefile	2007-12-04 02:41:16.000000000 -0800
+++ ./	2007-12-04 02:45:19.000000000 -0800
@@ -10,8 +10,7 @@
 COMMENT=	TCL/Expect-based framework for regression testing
-DEPENDS+=	tcl-expect>=5.32.1:../../lang/tcl-expect
+.include "../../lang/tcl-expect/"
 .include "../../mk/"