Subject: pkg/37472: emulators/snes9x fails to build on non-i386
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 12/04/2007 02:55:01
>Number:         37472
>Category:       pkg
>Synopsis:       emulators/snes9x fails to build on non-i386
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Dec 04 02:55:00 +0000 2007
>Originator:     Jared D. McNeill
>Release:        NetBSD 4.99.39
System: NetBSD 4.99.39 NetBSD 4.99.39 (GENERIC) #79: Mon Dec 3 18:58:20 EST 2007 amd64
Architecture: x86_64
Machine: amd64
	Trying to build emulators/snes9x on amd64:

	$ sudo make install
	=> Bootstrap dependency digest>=20010302: found digest-20070803
	ERROR: This package has set PKG_FAIL_REASON:
	ERROR: [] The package has no options, but includes this file.
	*** Error code 1

	make: stopped in /usr/pkgsrc/emulators/snes9x

	It appears that PKG_OPTIONS_VAR and are unconditionally
	used, but PKG_SUPPORTED_OPTIONS is only set if MACHINE_ARCH == i386.
	Attempt to build emulators/snes9x on something other than i386.