pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/37451: pkg_add allows to install conflicting packages

>Number:         37451
>Category:       pkg
>Synopsis:       pkg_add allows to install conflicting packages
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Nov 29 22:05:01 +0000 2007
>Originator:     Roland Illig
>Release:        pkgsrc-current
I have a binary package GConf-2.20 that conflicts with GConf2-[0-9]*. In my 
repository of binary packages, there are still packages that depend on the old 
GConf2 package, so when I pkg_add one of those packages, GConf2 gets installed 
although it conflicts with the new GConf package.


When installing a package, check that none of the installed packages conflicts 
with the to-be-added package.

Home | Main Index | Thread Index | Old Index