pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/37406: lang/perl5/ issue (net/nagios-base cannot be compiled)

>Number:         37406
>Category:       pkg
>Synopsis:       lang/perl5/ issue (net/nagios-base cannot be 
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Nov 20 08:40:00 +0000 2007
>Originator:     Naoto Morishima
>Release:        3.1_STABLE
etBSD xxx 3.1_STABLE NetBSD 3.1_STABLE (GENERIC 1.661.2.9) #1: Tue Apr  3 
21:31:15 JST 2007  xxx@xxx:/usr/obj/sys/arch/i386/compile/XXX i386
My friends found that comping net/nagios-base which requires perl>=5.6 
(according to net/nagios-base/Makefile.common) deletes lang/perl5 package even 
when the version of installed perl is 5.8.8nb4.

At CVS HEAD of pkgsrc, install lang/perl5 and try to compile net/nagios-base.
net/nagios-base/Makefile.common has the requirement that perl>=5.6, and 
net/nagios-base/Makefile includes ../../lang/perl5/  On the other 
hand, lang/perl5/ adds the requirement that perl>=5.8.7.  So at 
this moment, PERL5_REQD=5.6 5.8.7, but no file includes lang/perl5/, 
therefore pkgsrc system cannot resolve dependencies correctly.

Maybe lang/perl5/ or something should includes 
lang/perl5/, I guess?

Home | Main Index | Thread Index | Old Index