Subject: pkg/37135: LIBABISUFFIX support incomplete
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 10/16/2007 04:55:00
>Number:         37135
>Category:       pkg
>Synopsis:       LIBABISUFFIX support incomplete
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Oct 16 04:55:00 +0000 2007
>Originator:     Dan McMahill
>Release:        pkgsrc-2007Q3
System: Linux holding 2.4.21-50.EL #1 SMP Tue May 8 17:10:00 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

Architecture: x86_64
Machine: x86_64

packages which use imake to build do not really seem to work right on this 64-bit system.
Imake causes libraries to install into places like /usr/pkg/lib64 leaving the PLIST
which just uses lib completely broken.

The on top of that buildlinking doesn't really seem to work so well.  For example,
cd pkgsrc/x11/Xaw3d && make

and you find that it buildlinked /usr/X11R6/lib/libXaw.* instead of /usr/X11R6/lib64/libXaw.*
and the linker then complains that I have incompatible libraries.

For the PLIST issue, try installing pkgsrc/graphics/xpm.

The other issue is some libs build and install "correctly" into /usr/pkg/lib but
they are 64-bit libs where on this system it seems that 64-bit libs should go into


cd pkgsrc/x11/Xaw3d && make
cd pkgsrc/graphics/xpm && make



  a)  cause USE_IMAKE to trigger some special PLIST magic.
  b)  cause GNU_CONFIGURE to add something like --libdir=${PREFIX}/lib${LIBABISUFFIX} to
      CONFIGURE_ARGS and also trigger special PLIST magic.
  c)  cause the buildlink stuff to invoke special magic to link in the right libs

not sure what else.  Maybe some pkgconfig magic and foo-config magic?