Subject: pkg/37020: claws-mail-(plugin)
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 09/23/2007 17:25:00
>Number:         37020
>Category:       pkg
>Synopsis:       claws-mail-(plugin)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Sep 23 17:25:00 +0000 2007
>Originator:     Ondrej Tuma
>Release:        current
Linux ip1 #3 Thu Mar 8 18:42:01 CET 2007 i686 athlon-4 i386 GNU/Linux
ERROR: [] A package matching ``claws-mail-3.0.1'' should
ERROR:     be installed, but one cannot be found.  Perhaps there is a
ERROR:     stale work directory for ../../mail/claws-mail?
*** Error code 1
problem is in plugins Makefiles, here is:
DEPENDS+=       claws-mail-${CLAWS_VERSION}:../../mail/claws-mail

there is two solutions

set CLAWS_VERSION to full pkg_version (3.0.1nb1), or (better)
add char '*' after ${CLAWS_VERSION} like this:

DEPENDS+=       claws-mail-${CLAWS_VERSION}*:../../mail/claws-mail