pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/36514: libiconv conflits with nl_langinfo (CODESET) returning "646" on OpenBSD 4.1

>Number:         36514
>Category:       pkg
>Synopsis:       libiconv conflits with nl_langinfo (CODESET) returning "646" 
>on OpenBSD 4.1
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 20 08:05:00 +0000 2007
>Originator:     Alexander Nasonov
OpenBSD obx1000 4.1 GENERIC#1435 i386
This is a summary of a discussion on pkgsrc-users@

1. nl_langinfo (CODESET) returns "646" which is a synonym of "ASCII".
2. libiconv is not available on OpenBSD by default (only in ports).
3. pkgsrc's libiconv doesn't support codeset "646".

As a result, some packages fail to compile on OpenBSD 4.1. For exampe, gtk2 
cannot be build.

I reproduced it firt time when I tried to build gtk2. Or simply execute
$ echo "hello" | /usr/pkg/bin/iconv -f UTF-8 -t 646

Currently, it displays

$ echo "hello" | /usr/pkg/bin/iconv -f UTF-8 -t 646
/usr/pkg/bin/iconv: conversion to 646 unsupported
/usr/pkg/bin/iconv: try '/usr/pkg/bin/iconv -l' to get the list of supported 

Modify libiconv to support codeset "646"?

Home | Main Index | Thread Index | Old Index