Subject: Re: pkg/36492: editors/emacs (22.1) conflicts with lang/elisp-manual
To: None <,,>
From: Mark E. Perkins <>
List: pkgsrc-bugs
Date: 06/15/2007 00:25:02
The following reply was made to PR pkg/36492; it has been noted by GNATS.

From: "Mark E. Perkins" <>
To: Mark Davies <>
Cc: "Jeremy C. Reed" <>,
Subject: Re: pkg/36492: editors/emacs (22.1) conflicts with lang/elisp-manual
Date: Thu, 14 Jun 2007 20:21:15 -0400

 On 2007/06/14 20:09, Mark Davies wrote:
 > On Fri, 15 Jun 2007, Jeremy C. Reed wrote:
 >>> So now editors/emacs conflicts with lang/elisp-manual.
 >>>> Fix:
 >>> Need appropriate CONFLICTS statements in emacs Makefile and
 >>> in lang/elisp-manual.
 >> I don't use elisp. But is the lang/elisp-manual good enough or the
 >> same?
 >> Maybe editors/emacs should be taught not to install the info file
 >> -- and either depend on the lang/elisp-manual package or don't
 >> depend on it.
 > So thats where the elisp manual package is.  I went looking for it 
 > when I upgraded emacs but couldn't find it (because I was looking for 
 > emacs not elisp).
 The Intro to Emacs Lisp info files are there, as well.  There never was a
 package for those (I had my own private one at some point), but now all the
 relevant docs are bundled with Emacs (and I personally like having everything
 in one place).
 > To answer Jeremy's question, the elisp manual used to be shipped 
 > separately but with emacs22 its now bundled and there isn't a 
 > separate version so yes it needs the CONFLICTS statements.
 > cheers
 > mark
 Cheers, back
 Another Mark