Subject: pkg/36146: install-depends confused by old binary packages
To: None <,,>
From: Thomas Klausner <>
List: pkgsrc-bugs
Date: 04/14/2007 10:55:00
>Number:         36146
>Category:       pkg
>Synopsis:       install-depends confused by old binary packages
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Apr 14 10:55:00 +0000 2007
>Originator:     Thomas Klausner
>Release:        NetBSD 4.99.16
I'm using
        make DEPENDS_TARGET=bin-install install-depends
to install dependencies for a package using binary packages when they
already exist, and otherwise building from source.

However, if the existing binary package is not the same version as the
pkgsrc one, this first installs the (old) binary package, then builds
the new version from source and finally fails installing the new
version (because the old one is still installed). When I then run the
above target again, the installed package is found and used and pkgsrc
doesn't try to build the newer version again.

For example, this looks like:
=> Verifying bin-install for ../../x11/py-gnome2
===> Binary install for py24-gnome2>=2.12.4
=> Installing py24-gnome2-2.18.2 from /usr/pkgsrc/packages/All
py24-gnome2-2.16.2nb1 successfully installed.
=> No binary package found for py24-gnome2-2.18.2; installing from source.
[error during installation of py24-gnome2-2.18.2]
See above.
Not provided.