Subject: pkg/36017: sbcl fails build at sb-posix
To: None <,,>
From: brad harder <>
List: pkgsrc-bugs
Date: 03/15/2007 23:05:03
>Number:         36017
>Category:       pkg
>Synopsis:       sbcl doesn't build it's posix module, and fails
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 15 23:05:03 +0000 2007
>Originator:     brad harder <>
>Release:        NetBSD 4.0_BETA2
System: NetBSD manchester 4.0_BETA2 NetBSD 4.0_BETA2 (manchester) #23: Thu Mar 8 17:31:12 PST 2007 root@manchester:/usr/obj/sys/arch/i386/compile/manchester i386
Architecture: i386
Machine: i386
Make (using sbcl to build self) yields:
	; caught WARNING:
	;   undefined variable: *MAX-SAMPLES*

	; ==>
	; caught WARNING:
	;   undefined variable: *SAMPLE-INTERVAL*

	; caught WARNING:
	;   These variables are undefined:
	; compilation unit finished
	;   caught 4 WARNING conditions

	; compilation finished in 0:00:01
	* true
	make: Leaving directory `/usr/pkgsrc/lang/sbcl/work/sbcl-1.0.3/contrib/sb-sprof'

	WARNING! Some of the contrib modules did not build successfully or pass
	their self-tests. Failed contribs:"
		 60.96 real        48.50 user         2.70 sys
	 *** Error code 1

	 make: stopped in /usr/pkgsrc/lang/sbcl
	 *** Error code 1

	 make: stopped in /usr/pkgsrc/lang/sbcl

	I'm using sbcl (1.0.1) to build sbcl 1.0.3...
	A 'make' in pkgsrc/lang/sbcl will fail as described. I tried using CLISP for build before, but it never worked (notes iindicate that it seems to work once in a while, and recommend using sbcl to build self.

	using CLISP to try bootstrapping yields:
	*** - EVAL: undefined function HOST-CLOAD-STEM

	*** - EVAL: undefined function SB!VM:GENESIS
	The following functions were used but not defined:
	0 errors, 0 warnings
		11.14 real         8.36 user         0.51 sys
	//building runtime system and symbol table file
	make: Entering directory `/usr/pkgsrc/lang/sbcl/work/sbcl-1.0.3/src/runtime'
	GNUmakefile:31: genesis/Makefile.features: No such file or directory
	make: *** No rule to make target `genesis/Makefile.features'.  Stop.
	make: Leaving directory `/usr/pkgsrc/lang/sbcl/work/sbcl-1.0.3/src/runtime'
		0.01 real         0.00 user         0.00 sys
	*** Error code 2

	make: stopped in /usr/pkgsrc/lang/sbcl
	*** Error code 1

	make: stopped in /usr/pkgsrc/lang/sbcl