Subject: pkg/35863: "libxslt" (or "libxml2" package?) doesn't obey "PKG_SYSCONFDIR"
To: None <,,>
From: Matthias Scheler <>
List: pkgsrc-bugs
Date: 02/27/2007 21:20:01
>Number:         35863
>Category:       pkg
>Synopsis:       "libxslt" (or "libxml2" package?) doesn't obey "PKG_SYSCONFDIR"
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 27 21:20:01 +0000 2007
>Originator:     Matthias Scheler
>Release:        NetBSD 3.1_STABLE (2007-02-27 pkgsrc HEAD)
Matthias Scheler                        
System: NetBSD 3.1_STABLE NetBSD 3.1_STABLE (COLWYN) #0: Sat Feb 17 19:06:00 GMT 2007 i386
Architecture: i386
Machine: i386
Trying to build "htdocs" on my machine dies with this error message:

[xsltproc] layout.xml -> autolayout.xml
I/O error : Attempt to load network entity
warning: failed to load external entity ""
compilation error: file /src/NetBSD-current/htdocs/./share/xsl/autolayout.xsl line 9 element import
xsl:import : unable to load
*** Error code 5

The reason for that problem is that "xsltproc" is trying to open a file
called "/usr/pkg/etc/xml/catalog". But on my system that file is called
"/etc/pkg/xml/catalog" because "PKG_SYSCONFBASE" is set to "/etc/pkg".

I've tried to trace down the error. It is printed out by
xsltParseStylesheetImport() after calling a function provided by "libxml2".

I've tried to fix the "libxslt" and "libxml2" packages by adding the
missing "CONFIGURE_ARGS+= --sysconfig=${PKG_SYSCONFDIR:Q}" to the
"Makefile" but that didn't help.

1.) Put "PKG_SYSCONFBASE= /etc/pkg" in "/etc/mk.conf".
2.) Build the "netbsd-www" package from scratch.
3.) Try to run "make" in "htdocs".

Creating a symlink "/usr/pkg/etc/xml" pointing to "/etc/pkg/xml" works
arround the problem.