Subject: pkg/35594: upgrade sysutils/apcupsd to 3.14.0 (w/patch to do so)
To: None <,,>
From: Todd Kover <>
List: pkgsrc-bugs
Date: 02/13/2007 04:05:00
	Note: There was a bad value `non-cticial' for the field `Severity'.
	It was set to the default value of `serious'.

>Number:         35594
>Category:       pkg
>Synopsis:       upgrade sysutils/apcupsd to 3.14.0 (w/patch to do so)
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 13 04:05:00 +0000 2007
>Originator:     Todd Kover
>Release:        NetBSD 4.0_BETA2
Omniscient Technologies
System: NetBSD 4.0_BETA2 NetBSD 4.0_BETA2 (GENERIC) #3: Fri Dec 22 16:16:13 EST 2006 i386
Architecture: i386
Machine: i386
	3.14.0 is out.  I had issues getting 3.12.4 to work, though spent
	minimal time on it since the time seemed better spent on 3.14.0.

        The example apcupsd.conf file included in the distribution does
        not work.  I'm not sure what SOP is for these situations, so I
        included an apcupsd in the files directory that did work for
        me, though it does not get installed.  It's suitably generic to 
	be included in the pkg, if that's appropriate.

        I also added a patch so it does not install any of the files
        from ${WRKSRC}/platforms/{etc,netbsd} since a) they muck about
        with files in /etc and b) the pkgsrc framework takes care of
        installing everything from there, anyway.

        I did not fix the rc.d script so it honors standard NetBSD
        semantics (it doesn't use rc.conf or any of the other standard
        bits).  (It's been like this for many versions of apcupsd).

I've made a patch available at:  It's 500k
        long because it includes a new patch to configure (generated with
	autoconf), so I figured it best not to email.  This is how the old
	package was.

	please let me know if I should resubmit with the patch.