Subject: pkg/35496: net/latd fails to build with gcc4 on 4.0_BETA2
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 01/27/2007 09:50:00
>Number:         35496
>Category:       pkg
>Synopsis:       net/latd fails to build with gcc4 on 4.0_BETA2
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jan 27 09:50:00 +0000 2007
>Release:        NetBSD 4.0_BETA2
System: NetBSD panic 4.0_BETA2 NetBSD 4.0_BETA2 (PANIC) #1: Sun Jan 7 15:45:57 CET 2007 woodstoc@panic:/usr/obj/sys/arch/i386/compile.i386/PANIC i386
Architecture: i386
Machine: i386
When building on 4.0_BETA2 with gcc4, the following error occurs:
services.h:74: error: extra qualification 'LATServices::serviceinfo::' on member 'list_service'
try to build net/latd on 4.0_BETA2 with gcc4

--- services.h.orig	2002-10-14 16:33:46.000000000 +0200
+++ services.h	2007-01-26 13:25:00.000000000 +0100
@@ -71,7 +71,7 @@
       const std::string get_ident() { return ident; }
       bool         is_available();
       bool         remove_node(const std::string &node);
-      void         serviceinfo::list_service(std::ostrstream &output);
+      void         list_service(std::ostrstream &output);
       void         expire_nodes(time_t);