Subject: pkg/35221: lang/opencobol broken with new gmp
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 12/09/2006 18:15:00
>Number:         35221
>Category:       pkg
>Synopsis:       lang/opencobol broken with new gmp
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Dec 09 18:15:00 +0000 2006
>Originator:     David A. Holland /
>Release:        NetBSD 2.1.0_STABLE (pkgsrc 20061208)
   Harvard EECS
System: NetBSD bantha 2.1.0_STABLE NetBSD 2.1.0_STABLE (GENERIC) #3: Fri Dec  1 14:58:15 EST 2006  root@bantha:/usr/src/sys/arch/i386/compile/GENERIC i386
Architecture: i386
Machine: i386

lang/opencobol breaks with the new gmp (4.2.1) because it includes a
configure link test for an internal gmp function (__gmp_rand) that's
apparently turned into a macro.


Try to build lang/opencobol with today's pkgsrc. It will complain
about gmp needing to be newer than 3.something.


As a hack, disabling this test in should do the trick.

  AC_CHECK_LIB([gmp], [__gmp_rand], , AC_MSG_ERROR(GMP 3 or later is required))

However, one of the existing patches modifies configure and not; merging this is something of a hassle. So as a bigger

--- configure~	2006-12-09 12:51:49.000000000 -0500
+++ configure	2006-12-09 12:54:34.000000000 -0500
@@ -20736,6 +20736,9 @@
+# Test does not work with gmp 4.2.1, so force it
 echo "$as_me:$LINENO: checking for __gmp_rand in -lgmp" >&5
 echo $ECHO_N "checking for __gmp_rand in -lgmp... $ECHO_C" >&6
 if test "${ac_cv_lib_gmp___gmp_rand+set}" = set; then

I don't know for sure if opencobol *works* with the new gmp, but with
this hack it does configure and compile ok.

I haven't reported this upstream because it appears that our opencobol
(0.23) is seriously out of date; thinks current is 0.32
and it came out a year and a half ago. So probably the real fix is
just to update.