Subject: Re: pkg/35210: graphics/netpbm cannot be built under Interix-3.5
To: None <>
From: Aleksey Cheusov <>
List: pkgsrc-bugs
Date: 12/08/2006 23:12:03
 >>  >  What does upstream they about this? I think it is reasonable, but it
 >>  >  might be better to talk with the authors first. Infact, doing a real
 >>  >  configure check would be a better idea.

 >>  If I were upstream, I could tell "our software is correct, talk
 >>  to microsoft", but this is loooong way. I'll notify png upstream
 >>  maintainers anyway.

>  I meant using --version-script when it is not supported.  That
>  doesn't really sound like a png problem.
   a) MS's problem is that 'ld --help' lists not supported options.
   b) ld --version-script crashed somewhere internally,
      but ld's exit code is zero.
2) png's problem
   'ld --help' is too weak test for --version-script.

MS's problems are more serious, of course.

>  Or am I misunderstanding your problem?

Best regards, Aleksey Cheusov.