Subject: PR/34587 CVS commit: pkgsrc/lang/ruby18-base
To: None <,,,>
From: Takahiro Kambe <>
List: pkgsrc-bugs
Date: 12/06/2006 16:25:04
The following reply was made to PR pkg/34587; it has been noted by GNATS.

From: Takahiro Kambe <>
Subject: PR/34587 CVS commit: pkgsrc/lang/ruby18-base
Date: Wed,  6 Dec 2006 16:24:27 +0000 (UTC)

 Module Name:	pkgsrc
 Committed By:	taca
 Date:		Wed Dec  6 16:24:27 UTC 2006
 Modified Files:
 	pkgsrc/lang/ruby18-base: Makefile PLIST PLIST.common_end distinfo
 Added Files:
 	pkgsrc/lang/ruby18-base/patches: patch-af
 Removed Files:
 	pkgsrc/lang/ruby18-base/patches: patch-bl
 Log Message:
 o Update ruby18-base pacakge to Ruby 1.8 branch 2006/12/05.
 	- Many changes from 2006/9/6; see Changes file, please.
 	- Fixes another cgi.rb vulnerability:
 o Introduce ruby-build-ri-db PKG_OPTION which enable installing database
   for Ruby's ri utility.  Default is disabled and should be fix
   PR pkg/34587.
 To generate a diff of this commit:
 cvs rdiff -r1.28 -r1.29 pkgsrc/lang/ruby18-base/Makefile
 cvs rdiff -r1.8 -r1.9 pkgsrc/lang/ruby18-base/PLIST
 cvs rdiff -r1.1 -r1.2 pkgsrc/lang/ruby18-base/PLIST.common_end
 cvs rdiff -r1.16 -r1.17 pkgsrc/lang/ruby18-base/distinfo
 cvs rdiff -r0 -r1.1 pkgsrc/lang/ruby18-base/
 cvs rdiff -r0 -r1.1 pkgsrc/lang/ruby18-base/patches/patch-af
 cvs rdiff -r1.3 -r0 pkgsrc/lang/ruby18-base/patches/patch-bl
 Please note that diffs are not public domain; they are subject to the
 copyright notices on the relevant files.