Subject: Re: pkg/35015: devel/cmake needs a large datasize to compile
To: None <,,>
From: Robert Elz <kre@munnari.OZ.AU>
List: pkgsrc-bugs
Date: 11/08/2006 05:35:01
The following reply was made to PR pkg/35015; it has been noted by GNATS.

From: Robert Elz <kre@munnari.OZ.AU>
Subject: Re: pkg/35015: devel/cmake needs a large datasize to compile 
Date: Wed, 08 Nov 2006 12:31:54 +0700

     Date:        Wed,  8 Nov 2006 04:30:02 +0000 (UTC)
     From:        OBATA Akio <>
     Message-ID:  <>
   |  If you add
   |      UNLIMIT_RESOURCES=      datasize
   |  to Makefile, it's OK?
 Thanks for the quick reply.   When I saw it I thought "Oh, that's the
 pkgsrc magic that's needed" and tested it.   Unfortunately, it didn't
 work.   Just in case I'd made a cut/paste error from your mail, or in
 case of a typo there, I found other packages doing the same thing and
 cut/pasted the equivalent line from one of them - even though they looked
 identical.  (I even tried both the "=" and the "+=" variant that some
 packages use).
 None of those worked (same message as before at the same place).
 This was all with my default ulimit set back to its usual value.
 Then I tried again, with "ulimit -d ..." (whatever I put in the PR).
 Once again, that worked.
 So, either there is some problem using UNLIMIT_RESOURCES with pkg_comp
 (which is unlikely, many other packages seem to use it successfully).
 Or perhaps a problem using it with a package that uses gmake (along
 with whatever other build system this thing is using - perhaps even
 itself via some bootstrap or other), or alternatively, perhaps
 UNLIMIT_RESOURCES isn't unlimiting "enough" or something...
 ps: I also tried
 	UNLIMIT_RESOURCES=      datasize memorysize
 just in case, as some packages do that (though since I didn't touch
 ulimit -m when it worked, that seemed rather unliklely to help - and it didn't)