Subject: Re: pkg/34859: ruby with native pthread broken
To: None <>
From: Takayoshi Kochi <>
List: pkgsrc-bugs
Date: 10/20/2006 18:39:58
Hi Kambe-san,

>  > >Environment:
>  > NetBSD 3.1_RC4 on i386
>  > >Description:
>  > Trying to use bsfilter ( with ruby built from
>  > pkgsrc doesn't work correctly.
>  >
>  > This PR might belong to both pkg and lib(pthread).
>  Are you running this machine on VMWare as like PR pkg/34857?

No, 3.1RC_4 is running on a real i386 (Celeron 800MHz) machine.

I doubted my build was somewhat corrupt (like pkg/34857, though this
is not -current),
so today I refreshed my userland from daily snapshot build:

and tried the ruby with native pthread (rebuilt), but this happened again.
So this is reproducible on my environment.

To add some facts I learned, the ruby error "comparison of Fixnum with
Float failed"
appears pretty random.  I.e. sometimes this error occurs during
"bsfilter --update"
but sometimes not under the same condition.

Today I tried this on -current on i386/amd64 (as I can build ruby on
-current now ;)
but this problem didn't happen (though the testing is limited).

Now I am thinking of a possibility of a pthread locking problem that has been
fixed after 3.0 but before -current.

As the ruby with native pthread worked correctly on -current, I think
this is not
really a problem of ruby itself now.

Kambe-san, do you have any idea whether "comparison of Fixnum with Float failed"
can happen on `min' method for an array?

Takayoshi Kochi