Subject: Re: pkg/32398: Maintainer update: net/ipa 1.3.6 -> sysutils/ipa 2.0
To: None <>
From: Andrey Simonenko <>
List: pkgsrc-bugs
Date: 10/12/2006 13:08:09
On Sun, Oct 08, 2006 at 09:40:02AM +0000, OBATA Akio wrote:
> The following reply was made to PR pkg/32398; it has been noted by GNATS.
> From: OBATA Akio <>
> To:
> Cc:
> Subject: Re: pkg/32398: Maintainer update: net/ipa 1.3.6 -> sysutils/ipa 2.0
> Date: Sun, 8 Oct 2006 18:36:57 +0900
>  You are using WITH_XXX variables, please use options framework instead in pkgsrc.
>  And already 2.0.1 out.
>  Would you please regenerate diff?

I have NetBSD 2.0 and pkgsrc from the same release, I tried to update
pkgsrc, but it cannot be used on NetBSD 2.0.  I will try to rewrite
everything with options framework and will add some additions for
the current pkgsrc, but I will not be able to test them.

>  > *	Please remove ipa from net category and move it to
>  > 	sysutils, ipa-2.0 does not have anything common with
>  > 	network.
>  Is ipa-2.0 compatible with 1.x ?

ipa-2.x is a completely rewritten program.  It got some ideas from
the previous 1.x version.

In ipa-1.x support for firewalls and database was implemented directly
in source files.  ipa-2.x uses modules (accounting, database and
statistic modules, like plugins) and inside its source files there
is not any support for firewalls and databases, it simply work with
statistics (it can be anything) and solve some of accounting related

Right now there is not any accounting module, which can be used on
NetBSD.  Nevertheless, there is database module ipa_sdb, which can be
used on any Unix-like system and there is ipactl utility, which can
provide statistics.

Since ipa-2.x is a system independent program it can be used on any
Unix-like system.

>  > Problems in port (I cannot find out what's wrong):
>  > 
>  > 
>  >     *	When I run "make install" for port, "make install" runs
>  > 	${CC} to compile some of source files.  This does not happen
>  > 	if I run "./configure; make; make install" not from pkgsrc
>  > 	(Also I do not have this problem in FreeBSD with sysutils/ipa
>  > 	port).
>  > 
>  > 
>  >     *	New WITH_DEBUG_INFO variable does not work, "make install"
>  > 	runs "install ... -s ..." and all debugging information is
>  > 	removed.
>  Do you find to fix these problems?

Right now I cannot upgrade my system, so I use old pkgsrc, but
the first problem looks strange, because "make install" recompiles
some of source files (not all of them).