Subject: pkg/34548: doc/guide fails to detect ghostscript
To: None <,,>
From: Ben Collver <>
List: pkgsrc-bugs
Date: 09/17/2006 23:40:00
>Number:         34548
>Category:       pkg
>Synopsis:       doc/guide fails to detect ghostscript
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Sep 17 23:40:00 +0000 2006
>Originator:     Ben Collver
>Release:        Darwin 8.7.1 i386

System: Darwin 8.7.1 Darwin Kernel Version 8.7.1: Wed Jun  7 16:19:56 PDT 2006; root:xnu-792.9.72.obj~2/RELEASE_I386 i386


I have ghostscript-gnu installed, but the pkgsrc guide fails to build because it wants ghostscript-gnu-nox11.  It should accept both.


$ cd pkgsrc/doc/guide && make
[Checking tools for typesetting...NG]
===> ERROR: The following packages are missing for typesetting:
      - ghostscript-esp>=7.05
      - ghostscript-esp-nox11>=7.05
      - ghostscript-gnu-nox11>=7.05
  Make sure to install the latest package of meta-pkgs/netbsd-doc
  via pkgsrc.  For printable formats, meta-pkgs/netbsd-doc-print is needed.
*** Error code 1


$ pkg_info|grep -e ghostscript -e netbsd-doc
ghostscript-fonts-8.11 Postscript fonts for Aladdin Ghostscript
ghostscript-gnu-8.15nb4 GNU Postscript interpreter with all drivers
netbsd-doc-1.2nb1   Meta-package including all packages to convert SGML->HTML
netbsd-doc-print-1.2nb1 Meta-package including all packages to convert SGML->PDF/PS


Not sure.