Subject: Re: pkg/34167 (meta-pkgs/xfce4-extras won't build on current (disk.h))
To: None <>
From: Martti Kuparinen <>
List: pkgsrc-bugs
Date: 09/07/2006 09:00:19
ROOT n117:/usr/pkgsrc/sysutils/xfce4-diskperf-plugin> make install
=> Registering installation for xfce4-diskperf-plugin-1.5nb3
xfce4-diskperf-plugin-1.5nb3 requires installed package glib2-2.12.3
xfce4-diskperf-plugin-1.5nb3 requires installed package xfce4-panel-4.2.3nb4

I have this system:

# uname -srm
NetBSD 4.99.1 i386

# ident /usr/include/sys/disk.h /usr/src/sys/sys/disk.h
     $NetBSD: disk.h,v 1.36 2006/04/21 13:53:30 yamt Exp $

     $NetBSD: disk.h,v 1.36 2006/04/21 13:53:30 yamt Exp $

So this works for me on the latest current (I reinstalled /usr/include so
I don't have disk_sysctl in disk.h):

Could you upgrade to the latest current and do this:

# find /usr/include -type l -o -type f -exec rm {} \;
# cd /usr/src
# make includes

# cd /usr/pkgsrc/sysutils/xfce4-diskperf-plugin
# make clean clean-depends
# make install