Subject: lang/perl5 build problem
To: None <>
From: =?UTF-8?Q?=D0=9B=D0=B5=D0=B1=D0=B5=D0=B4=D0=B5=D0=B2_?= =?UTF-8?Q?=D0=90=D0=BB=D0=B5=D0=BA=D1=81=D0=B5=D0=B9_?= =?UTF-8?Q?=D0=92=D0=BB=D0=B0=D0=B4=D0=B8=D0=BC=D0=B8=D1=80=D0=BE=D0=B2?= =?UTF-8?Q?=D0=B8=D1=87?= <>
List: pkgsrc-bugs
Date: 08/22/2006 12:07:04
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable


This is my first e-mail to

I can't build lang/perl5 on our system.

We're using pkgsrc as primary package system on our linux-servers and
having problem on one runing on AMD64.

Uname -a:
Linux 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:56:28 EST
2006 x86_64  x86_64 x86_64 GNU/Linux

PKG_OPTIONS.perl (not defined)

pkgsrc is from head of cvs.

Any suggestions would be very appriciated. Thanks.

Alexey Lebedev
tel.: +7 903 521-71-99

Build log:

/usr/pkgsrc/lang/perl5# bmake
=3D=3D=3D> Checking for vulnerabilities in perl-5.8.8nb2
=3D> Checksum SHA1 OK for perl-5.8.8.tar.bz2.
=3D> Checksum RMD160 OK for perl-5.8.8.tar.bz2.
=3D=3D=3D> Installing dependencies for perl-5.8.8nb2
The supported build options for this package are:


The currently selected options are:


You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

        PKG_OPTIONS.perl (not defined)

The following variables will affect the build process of this package,
perl-5.8.8nb2.  Their current value is shown below:

        * PERL5_SITEPREFIX (defined)

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/pkg/bin/bmake clean' after
the changes.
=3D=3D=3D> Overriding tools for perl-5.8.8nb2
=3D=3D=3D> Extracting for perl-5.8.8nb2
=3D=3D=3D> Patching for perl-5.8.8nb2
=3D> Applying pkgsrc patches for perl-5.8.8nb2
=3D=3D=3D> Creating toolchain wrappers for perl-5.8.8nb2
=3D=3D=3D> Configuring for perl-5.8.8nb2
hintdir=3D"/usr/pkgsrc/lang/perl5/work/perl-5.8.8/hints"; for hints in
${hintdir}/*.sh; do                                 /bin/chmod +w
${hints};                                         { echo ""; echo "cat >
UU/pkgsrc.cbu <<'EOCBU'";            echo "# This script UU/pkgsrc.cbu
will get 'called-back' by Configure to set";  echo '# linker options
after all other call-back scripts have been invoked.';  echo
'ldflags=3D"'-Wl,-R/usr/pkg/lib' $ldflags"';  echo
'lddlflags=3D"'-Wl,-R/usr/pkg/lib' $lddlflags"';  echo
"EOCBU";                                      } >> ${hints}; done
hintdir=3D"/usr/pkgsrc/lang/perl5/work/perl-5.8.8/hints"; for hints in
${hintdir}/*.sh; do                                 /bin/chmod +w
${hints};                                         { echo ""; echo "# Set
pkgsrc defaults for library and header search paths.";  echo
'locincpth=3D"'/usr/pkg/include'"';               echo
'loclibpth=3D"'/usr/pkg/lib'"'; } >> ${hints};
First let's make sure your kit is complete.  Checking...
Locating common programs...
Checking compatibility
between /usr/pkgsrc/lang/perl5/work/.tools/bin/echo and builtin echo (if
Symbolic links are supported.
Checking how to test for symbolic links...
You can test for symbolic links with 'test -h'.
Good, your tr supports [:lower:] and [:upper:] to convert case.
Using [:upper:] and [:lower:] to convert case.
3b1          dos_djgpp       irix_6        next_4        stellar
aix          dragonfly       irix_6_0      nonstopux     sunos_4_0
aix_3        dynix           irix_6_1      openbsd       sunos_4_1
aix_4        dynixptx        isc           opus          super-ux
altos486     epix            isc_2         os2           svr4
amigaos      esix4           linux         os390         svr5
apollo       fps             lynxos        os400         ti1500
atheos       freebsd         machten       posix-bc      titanos
aux_3        genix           machten_2     powerux       ultrix_4
beos         gnu             mint          qnx           umips
bsdos        gnukfreebsd     mips          rhapsody      unicos
convexos     gnuknetbsd      mpc           sco           unicosmk
cxux         greenhills      mpeix         sco_2_3_0     unisysdynix
cygwin       hpux            ncr_tower     sco_2_3_1     utekv
darwin       i386            netbsd        sco_2_3_2     uts
dcosx        interix         newsos4       sco_2_3_3     uwin
dec_osf      irix_4          next_3        sco_2_3_4     vmesa
dgux         irix_5          next_3_0      solaris_2     vos
Which of these apply, if any? [linux]

You appear to have ELF support.  I'll try to use it for dynamic loading.
If dynamic loading doesn't work, read hints/ for further
Operating system name? [linux]
Operating system version? [2.6.9-34.elsmp]
Build Perl for SOCKS? [n]
Use the PerlIO abstraction layer? [y]
Build a threading Perl? [y]
Use the newer interpreter-based ithreads? [y]
Use which C compiler? [gcc]
Checking for GNU cc in disguise and/or its version number...
Now, how can we feed standard input to your C preprocessor...
Directories to use for library searches?
[/lib /usr/lib /usr/local/lib /usr/pkg/lib]
What is the file extension used for shared libraries? [so]
Try to use long doubles if available? [n]
Checking for optional libraries...
What libraries to use? [-lgdbm]
What optimizer/debugger flag should be used?
[-O2 -Wno-format -fno-builtin -pthread -I/usr/include]
Any additional cc flags?
-pipe -Wdeclaration-after-statement -I/usr/pkg/include]
Let me guess what the preprocessor flags are...
Any additional ld flags (NOT including libraries)? [ -L/usr/pkg/lib]
Checking your choice of C compiler and flags for coherency...
I've tried to compile and run the following simple program:

#include <stdio.h>
int main() { printf("Ok\n"); return(0); }

I used the command:

        gcc -o try -O2 -Wno-format -fno-builtin -pthread -I/usr/include
-pipe -Wdeclaration-after-statement -I/usr/pkg/include -L/usr/pkg/lib
try.c -lgdbm

and I got the following output:

/usr/bin/ld: cannot find -lgdbm
collect2: ld returned 1 exit status
I can't compile the test program.
You have a BIG problem.  Shall I abort Configure [y]
Ok.  Stopping Configure.
*** Error code 1

bmake: stopped in /usr/pkgsrc/lang/perl5
=3D=3D=3D> There was an error during the ``configure'' phase.
=3D=3D=3D> Please investigate the following for more information:
=3D=3D=3D>      * log of the build
=3D=3D=3D>      * /usr/pkgsrc/lang/perl5/work/.work.log
*** Error code 1

bmake: stopped in /usr/pkgsrc/lang/perl5

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.4.5 (FreeBSD)