Subject: Re: pkg/34149 (angband-tty doesn't work after recent update)
To: None <,,>
From: Quentin Garnier <>
List: pkgsrc-bugs
Date: 08/06/2006 21:55:02
The following reply was made to PR pkg/34149; it has been noted by GNATS.

From: Quentin Garnier <>
To: David Holland <>
Subject: Re: pkg/34149 (angband-tty doesn't work after recent update)
Date: Sun, 6 Aug 2006 23:54:26 +0200

 Content-Type: text/plain; charset=us-ascii
 Content-Disposition: inline
 Content-Transfer-Encoding: quoted-printable
 On Sun, Aug 06, 2006 at 05:40:19PM -0400, David Holland wrote:
 >  > Patch un-applied:  SETGIDGAME is not to be set by a package.
 > Hm... oops.
 > I admit I didn't look at (or look for) the documentation for
 > SETGIDGAME, but now that I have I don't think it would have stopped me
 > from drawing the conclusion that I did.
 Well, I did that mistake too, so can't blame ya.
 > It should probably be renamed SETGIDGAMES, and the documentation
 > should say that it's not supposed to be set by packages. (Otherwise
 > doubtless other people will continue to make the same mistake. As of
 > yesterday three games set it explicitly: tanked, xgalaga, and
 > xscrabble.)
 > Probably a better long-term approach would be to have it go by putting
 > setgid in $(PKG_OPTIONS).foo, but that's also probably a lot of work.
 I don't think it makes much sense to not have it on by default when
 installing with privileges.  I'll start a discussion on tech-pkg.
 > As for fixing angband... before anyone goes in and starts patching it,
 > it's probably a good idea to update to the latest version. And to
 > clean up the divergence between angband-tty and angband-x11, too.
 Yeah.  I'll ping the maintainer.
 > Sigh. And here I thought this was an easy one...
 Famous last words.
 Quentin Garnier - -
 "When I find the controls, I'll go where I like, I'll know where I want
 to be, but maybe for now I'll stay right here on a silent sea."
 KT Tunstall, Silent Sea, Eye to the Telescope, 2004.
 Content-Type: application/pgp-signature
 Content-Disposition: inline
 Version: GnuPG v1.4.3 (NetBSD)