Subject: pkg/34126: postgresql-client conflicts not detected
To: None <,,>
From: Andreas Gustafsson <>
List: pkgsrc-bugs
Date: 08/02/2006 12:50:00
>Number:         34126
>Category:       pkg
>Synopsis:       postgresql-client conflicts not detected
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Aug 02 12:50:00 +0000 2006
>Originator:     Andreas Gustafsson
>Release:        NetBSD 3.99.21
System: NetBSD 3.99.21 NetBSD 3.99.21 (GENERIC) #1: Wed Jul 5 19:33:35 EEST 2006 i386
Architecture: i386
Machine: i386

If you try to install both postgresql81-client and
postgresql80-client, they end up overwriting each other's file,
causing hundreds of error messages like the following:

  pkg_add: Overwriting /usr/pkg/include/postgresql/server/storage/pg_sema.h - pkg postgresql80-client-8.0.8 bogus/conflicting?

Although it may be unlikely that you would specify both of those
packages explicitly, you can easily end up with a conflict
accidentally as a result of package interdependencies.  For example,
if you try to install these two binary packages:

the latter will pull in postgresql80-client as a dependency and
bad things happen.


  pkg_add postgresql80-client-8.0.8.tgz
  pkg_add postgresql81-client-8.1.4.tgz


Not provided.