Subject: pkg/34115: pkgsrc/xine-arts doesn't build using pkgsrc current as of this morning
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 07/30/2006 15:55:00
>Number:         34115
>Category:       pkg
>Synopsis:       pkgsrc/xine-arts doesn't build using pkgsrc current as of this morning
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jul 30 15:55:00 +0000 2006
>Originator:     Andy Ruhl
>Release:        netbsd-3
NetBSD speedy 3.0_STABLE NetBSD 3.0_STABLE (GENERIC) #0: Fri May 19 12:27:37 MST 2006  root@speedy:/usr/obj-amd64-r3/sys/arch/amd64/compile/GENERIC amd64
xine-arts doesn't build, which is a dependency for kdeartwork3, which is a dependency for the meta package kde3.

Here is what the output is:

# make package
=> Required installed package digest>=20010302: digest-20021220 found
===> Skipping vulnerability checks.
WARNING: No /usr/pkgsrc/distfiles/pkg-vulnerabilities file found.
WARNING: To fix, install the pkgsrc/security/audit-packages
WARNING: package and run: ``/usr/pkg/sbin/download-vulnerability-list''.
=> Checksum SHA1 OK for xine-lib-1.0.3a.tar.gz
=> Checksum RMD160 OK for xine-lib-1.0.3a.tar.gz
===> Installing dependencies for xine-arts-1.0.3anb3
=> Required installed package libtool-base>=1.5.18nb5: libtool-base-1.5.18nb5 found
=> Required installed package autoconf>=2.50: autoconf-2.59 found
=> Required installed package gmake>=3.78: gmake-3.80nb4 found
=> Required installed package pkg-config>=0.19: pkg-config-0.20 found
=> Required installed package xine-lib>=1rc3a: xine-lib-1.0.3anb11 found
=> Required installed package freetype2>=2.1.10nb1: freetype2-2.1.10nb2 found
=> Required installed package arts>=1.5.1nb1: arts-1.5.2 found
===> Overriding tools for xine-arts-1.0.3anb3
===> Extracting for xine-arts-1.0.3anb3
===> Patching for xine-arts-1.0.3anb3
=> Applying pkgsrc patches for xine-arts-1.0.3anb3
Ignoring patch file /usr/pkgsrc/audio/xine-arts/../../multimedia/xine-lib/patches/patch-at: invalid checksum
Ignoring patch file /usr/pkgsrc/audio/xine-arts/../../multimedia/xine-lib/patches/patch-bf: no checksum found
ERROR: Patching failed due to modified or broken patch file(s):
ERROR:  /usr/pkgsrc/audio/xine-arts/../../multimedia/xine-lib/patches/patch-at
*** Error code 1

make: stopped in /usr/pkgsrc/audio/xine-arts
*** Error code 1

make: stopped in /usr/pkgsrc/audio/xine-arts
get latest pkgsrc as of 08:30 AM MST via cvs

cd /usr/pkgsrc/audio/xine-arts && make package
Not known, patches don't apply so they probably need to be updated