Subject: pkg/34099: programs using xorg-libs crash with signal 10 on amd64
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 07/27/2006 15:30:00
>Number:         34099
>Category:       pkg
>Synopsis:       programs using xorg-libs crash with signal 10 on amd64
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jul 27 15:30:00 +0000 2006
>Originator:     Khelban Blackstaff
>Release:        3.99.22
NetBSD hostname 3.99.22 NetBSD 3.99.22 (mykern) #0: Sun Jul 16
19:56:46 EEST 2006  root@hostname:/usr/obj/usr/src/sys/arch/amd64/compile/mykern 

I have an Intel P4 processor and use the amd64 NetBSD port.
I compiled xorg-libs which compiled fine. But, every
program using or any other lib crashes with
signal 10.

I have tried the following command "gdb command -c command.core"
The output of the gdb is the following:

This GDB was configured as "x86_64--netbsd"...(no debugging symbols
found)... Core was generated by `xclock'.
Program terminated with signal 10, Bus error.
Reading symbols from /usr/pkg/lib/
(no debugging symbols found)...done.
Loaded symbols for /usr/pkg/lib/
more libraries loading
Loaded symbols for /usr/libexec/ld.elf_so
#0  0x00007f7ffc028e98 in XFindOnExtensionList ()
   from /usr/pkg/xorg/lib/
(gdb) quit

I use the latest pkgsrc cvs as of now (time of writing this).

Compile xorg-libs on the amd64 port and then use any program that
is linked with some lib (e.g xterm)

Mihai CHELARU <> 

pointed me to use "-fno-strict-aliasing" and recompile the
xorg-libs package which worked fine. Now all packages work
ok and don't crash

the xorg-libs package didn't honour CFLAGS,CXXFLAGS from
my mk.conf so i put the option in DefaultCCOptions in