Subject: pkg/33856: Aide needs to buildlink zlib
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 06/28/2006 21:45:01
>Number:         33856
>Category:       pkg
>Synopsis:       Aide needs to buildlink zlib
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 28 21:45:01 +0000 2006
>Originator:     Lloyd Parkes
>Release:        Solaris 9
Inland Revenue
SunOS 5.9 Generic_118558-28 sun4u sparc SUNW,UltraAX-i2
Aide requires zlib, but the security/aide Makefile doesn't have a buildink include for it.
Type bmake on a Solaris box and watch it not build

    checking for zlib.h... yes
    checking for gzdopen in -lz... no
    configure: error: You don't have zlib properly installed.
    Install it or try --without-zlib.
    *** Error code 1

    bmake: stopped in /home/lloyd/pkgsrc/security/aide

Add the following line to pkgsrc/security/aide/Makefile

    .include "../../devel/zlib/"