Subject: Re: pkg/33652 (several packages are missing dependencies)
To: None <,,>
From: Steven M. Bellovin <>
List: pkgsrc-bugs
Date: 06/07/2006 00:15:05
The following reply was made to PR pkg/33652; it has been noted by GNATS.

From: "Steven M. Bellovin" <>
Subject: Re: pkg/33652 (several packages are missing dependencies)
Date: Tue, 6 Jun 2006 20:12:15 -0400

 On Tue, 06 Jun 2006 18:31:43 -0400, "Johnny C. Lam"
 <> wrote:
 > Steven M. Bellovin wrote:
 > > Things seem better but not, I think, perfect -- here's what I just got
 > > after deleting gnome-2.14.0 py23-gnome2-2.12.4nb1 py23-gnome2-extras-2.12.0nb7 py23-gtk2-2.8.6 deskbar-applet-
 > > 
 > > ===> Returning to build of py23-gnome2-2.12.4nb1
 > > ===> Required installed package py23-gtk2>=2.8.4: py23-gtk2-2.8.6 found
 > > ===> Required installed package py24-gtk2>=2.8.5nb1: NOT found
 > > ===> Verifying package for ../../x11/py-gtk2
 > > ===> Checking for vulnerabilities in py24-gtk2-2.8.6
 > > => Checksum SHA1 OK for pygtk-2.8.6.tar.bz2.
 > > => Checksum RMD160 OK for pygtk-2.8.6.tar.bz2.
 > > ===> Overriding tools for py24-gtk2-2.8.6
 > > ERROR: [] A package matching ``py24-gtk2>=2.8.5nb1'' should
 > > ERROR:     be installed, but one cannot be found.  Perhaps there is a
 > > ERROR:     stale work directory for ../../x11/py-gtk2?
 > > *** Error code 1
 > > 
 > > Stop.
 > I've investigated some more.  The reason for the failure is that 
 > deskbar-applet package directly and indirectly depends on two different 
 > versions of py-gtk2, namely py23-gtk2 and py24-gtk2.  The problem is 
 > that they are built from the same x11/py-gtk2 directory, so if, e.g. 
 > py23-gtk2 is installed and the work directory is not removed, than any 
 > subsequent build in x11/py-gtk2 will automatically return as a success 
 > because of the presence of the "install cookie" from the previous 
 > installation.
 > I think you could get a successful build by removing the work directory 
 > for x11/py-gtk2 manually.  Longer term, I think it would be best if you 
 > directly set PYTHON_VERSION_DEFAULT to "24" in /etc/mk.conf to force 
 > python-2.4.x to be installed to satisfy Python dependencies. 
 > Unfortunately, you would need to "pkg_delete -r python23" to remove the 
 > old Python and all packages that depended on it would have to be rebuilt.
 In fact, I want to have only Python 2.4; I'll happily do that.  It worked,
 so I have no immediate problems.
 I wonder if there's some solution involing package options, perhaps
 specifying the version of python to use if there's no default set.
 		--Steven M. Bellovin,