Subject: Re: pkg/33254 (default install of libao results in no audio output
To: None <,,>
From: Havard Eidnes <>
List: pkgsrc-bugs
Date: 04/14/2006 23:40:03
The following reply was made to PR pkg/33254; it has been noted by GNATS.

From: Havard Eidnes <>
Subject: Re: pkg/33254 (default install of libao results in no audio output
 on NetBSD)
Date: Sat, 15 Apr 2006 01:36:24 +0200 (CEST)

 > Try the libao-sun and libao-oss packages.
 Why should I have to?
 Perhaps I should have stated it more clearly: the user-level problem
 is that gqmpeg doesn't appear to be able to play any Ogg Vorbis
 encoded files on NetBSD.  If gqmpeg is started from an xterm (not
 always the case), it spits out "ogg123 vanished" or something to that
 effect when it's pointed to an ogg file.  ogg123 on its part lists
 "null" as the only supported real-time output device.  The reason
 appears to be that libao is misconfigured.
 I cannot totally rule out that this isn't a problem with my local
 installation, but it appears to me that a binary package install of
 gqmpeg, or for that matter, a default install of gqmpeg (which will
 pull in vorbis-tools and libao), will, on NetBSD, result in a gqmpeg
 which isn't able to play ogg files.  I think this is broken, and that
 it needs fixing, without telling every user that "well, the default
 selection is broken, go and build this one from source yourself".
 vorbis-tools/Makefile does
 .include "../../audio/libao/"
 so this one will be picked by default.  In that file I see some
 attempts at selecting "default plugin" based on which OS this is
 compiled for, but none of it appears to have any effect.
 I think this is broken, and that this needs to be fixed, not
 - H=E5vard