Subject: pkg/33233: "gnome-vfs2" broken under Mac OS X
To: None <,,>
From: Matthias Scheler <>
List: pkgsrc-bugs
Date: 04/10/2006 20:10:00
>Number:         33233
>Category:       pkg
>Synopsis:       "gnome-vfs2" broken under Mac OS X
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Apr 10 20:10:00 +0000 2006
>Originator:     Matthias Scheler
>Release:        Darwin 8.6.0
Matthias Scheler                        
System: Darwin 8.6.0 Darwin Kernel Version 8.6.0: Tue Mar  7 16:58:48 PST 2006; root:xnu-792.6.70.obj~1/RELEASE_PPC Power Macintosh powerpc
Architecture: powerpc
Machine: Power Macintosh
Building version 2.14.0 of the "gnome-vfs2" package doesn't work under
Mac OS X (aka Darwin). The following GNOME bugs contain the details:

This bug is only a placeholder to track that the issue is known because
this is really bug in GNOME. The problem happesn with the original
"libtool" and without Buildling 3, too.

cd pkgsrc/sysutils/gnome-vfs2

The following patch works arround GNOME bugs 337993 and 338007. I've not
found a fix for bug #338015 so far.

Index: Makefile
RCS file: /cvsroot/pkgsrc/sysutils/gnome-vfs2/Makefile,v
retrieving revision 1.62
diff -u -r1.62 Makefile
--- Makefile	6 Apr 2006 06:22:45 -0000	1.62
+++ Makefile	10 Apr 2006 17:49:35 -0000
@@ -22,6 +22,17 @@
 .include "Makefile.common"
+# This should be removed after the GNOME maintainers fix the problems
+# with "neon" under Mac OS X.
+.if ${OPSYS} == Darwin
+CONFIGURE_ARGS+=	--disable-http-neon
+SUBST_STAGE.neon=	post-configure
+SUBST_FILES.neon=	imported/Makefile
+SUBST_SED.neon=		-e 's/^\(SUBDIRS =.*\) neon/\1/'
 .include "../../devel/GConf2/"
 .include "../../archivers/bzip2/"