Subject: pkg/33195: Gnome-panel-2.14.0 needs gettext >=0.10.36 for translations
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 04/05/2006 03:20:00
>Number:         33195
>Category:       pkg
>Synopsis:       Gnome-panel-2.14.0 needs gettext >=0.10.36 for translations
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Wed Apr 05 03:20:00 +0000 2006
>Originator:     Eddahbi Karim
>Release:        NetBSD 3.0
NetBSD PouipPouip 3.0 NetBSD 3.0 (MOIMOI) #4: Sat Apr  1 10:20:01 UTC 2006  root@PouipPouip:/usr/src/sys/arch/i386/compile/MOIMOI i386

Gnome-panel translations files ( .gmo files ) needs gettext version >=0.10.36 in order to compile correctly because translations files use 'msgid_plural' which has been added to gettext 0.10.36 according to 

Since the system comes with gettext 0.10.35, I think that pkgsrc's Makefile used to build gnome-panel >=2.14 should check for gettext >=0.10.36 before trying to build the software.
- Install gettext 0.10.35
- Build gnome-panel with all translations
- Check for gettext's version and upgrade gettext if version is below 0.10.36.